# Resource does not support attribute type Endpoint in Fn::GetAtt

**URL:** <https://discourse.sst.dev/t/resource-does-not-support-attribute-type-endpoint-in-fn-getatt/1993>\
**Category:** Seed\
**Created:** [July 30, 2020, 6:55am UTC](https://discourse.sst.dev/t/resource-does-not-support-attribute-type-endpoint-in-fn-getatt/1993 "2020-07-30T06:55:13Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![garycjohnson](https://yyz2.discourse-cdn.com/flex032/user_avatar/discourse.sst.dev/garycjohnson/32/946_2.png) [@garycjohnson](https://discourse.sst.dev/u/garycjohnson)\
**Post date:** [July 30, 2020, 6:55am UTC](https://discourse.sst.dev/t/resource-does-not-support-attribute-type-endpoint-in-fn-getatt/1993/1 "2020-07-30T06:55:14Z")

</div>

I’ve already resolved this issue but I was banging my head against the wall for a while so thought I’d post it here.

My serverless service would deploy fine when using **sls deploy** from the command line but failed when I was using seed to manage the deployment.

The error was … _The CloudFormation template is invalid: Template error: resource xxxxxxxx does not support attribute type Endpoint in Fn::GetAtt_. The YML for this looked like …

```auto
RDSEndpoint:
  Value:
    Fn::GetAtt:
      - DBInstance
      - Endpoint.Address
  Export:
    Name: my-app-${self:custom.stage}-RDSEndpoint

```

It turns out the answer was to put double quotes around `"Endpoint.Address"`.

Hope that helps someone.

---

<div class="post-metadata">

**Author:** ![jayair](https://yyz2.discourse-cdn.com/flex032/user_avatar/discourse.sst.dev/jayair/32/9_2.png) [@jayair](https://discourse.sst.dev/u/jayair)\
**Post date:** [August 1, 2020, 6:37pm UTC](https://discourse.sst.dev/t/resource-does-not-support-attribute-type-endpoint-in-fn-getatt/1993/2 "2020-08-01T18:37:23Z")

</div>

Ah I see. Thanks for sharing!
