Cannot find `runtime` in the `serverless.yml`

Hi there,

I’ve followed this chapter and added some new services.

My build phases looks like this:

And I gets this error:

I have added the runtime in my serverless.yml:

Here is my folder structure:

Some of the services fails with another error, that dosen’t shows me very much detailed information:

Any ideas to what I am missing?

Kind regards.

Can you also post a link to your app on Seed? We’ll take a look and see what is going on.

The Cannot find runtime error usually happens if Seed is unable to parse the serverless.yml. It’s not a great error message (we’ll fix that). But I would check your serverless.yml to see if it is indented properly.

For the other error. Have you tried deploying that from your local? It seems like it serverless is looking for a file that it cannot find.

Thanks, that helped! Now I only receives the error shown in the last picture. Any ideas to what “No file matches include / exclude patterns”?

Kind regards

Hmm I’m not entirely sure. It seemed like some of your services were deploying a Lambda function but there were no .js files in the directory. Not sure if that is causing it.

Okay, will try to debug some more. According to the repo that Seed is connected to, there is .js files in all the correct folders. I have tried with /services/service/, services/service, services/service but it dosen’t seem to be a problem with the path, since it gives the same error.