How to create an Expo app with serverless

Link to chapter — https://serverless-stack.com/examples/how-to-create-an-expo-app-with-serverless.html

This tutorial was great! Just one problem: I successfully deployed to prod but when I execute the command for the prod cli (npx sst console --stage prod) it looks like I need to specify a port somehow? This is what’s returned: SST Console: https://console.sst.dev/serverless-backend/prod/stacks?_port=undefined.

Oh good catch. We just rolled out a fix for it in:

1 Like

I’m having an issue with the sst remove command - not just here but with the notes demo app in the guide. I run the command and everything goes off without a hitch. Then, without changing anything else, I try to rebuild it with sst start. The command executes, building the app just as you would expect until it gets to the step where it attempts to create the Dynamo DB at which point I get this error:


This is especially strange because when I log into the aws console and view my dynamo db tables I can see that I don’t have any. I even checked via the aws cli with aws dynamodb list-tables and I don’t have any tables.

Following up on this post. Turns out, my aws-cli and console had different default regions set from what is specified in my sst.json. Once I synced my aws cli to the right region via aws configure set default.region us-east-1 and used the aws dynamodb list-tables I was able to see all the tables generated through sst. However, even after setting the region, when I run sst remove I still hit the same error. I had to manually use the aws cli to delete the offending table: aws dynamodb delete-table --table-name dev-notes-Notes.