Problem while creating user pool

In the guide here, as they suggest, we need to set Username attributes to email, but when I do it, I am not able to create my User Pool. Then, I keep getting this error.

1 validation error detected: Value '[]' at 'schema' failed to satisfy constraint: Member must have length greater than or equal to 1 (Service: AWSCognitoIdentityProviderService; Status Code: 400; Error Code: InvalidParameterException; Request ID: 2d84e736-e114-41b4-b730-7e35f5783832)

If I leave it everything as a default, it creates the User pool

In order to fix the problem, We must set something to Required attributes. In this case, I set it as email, and now it works.

Thanks for letting us know. Was it in this screen that you changed the required attribute?

Yes, It was in this screen. We have two option for this situation in order to fix it.

First option: We can choose the Username option, and leave it as a default. However, it did not let me to create test user because it throws error about email configuration in the console while I was trying to set it.

Second option: When we choose Email address or phone number option as the guide suggests, we must also choose email as a required attribute at the bottom of the page.

I added screenshot the way I configure

1 Like

Thanks! I’ll update the guide with this.

Edit: It’s weird I just tried going through the steps and I’m not seeing the error. I wonder if it was an AWS bug and they fixed it. I’ll add a note in any case.

1 Like

Today, earlier in the morning, I checked it again. I think it was sum-sort of a bug. They fixed it.

Yeah definitely seemed like a bug.