Comments for Set up SSL

From @jayair on Mon Apr 10 2017 01:10:00 GMT+0000 (UTC)

Link to chapter -

Copied from original issue:

From @geirman on Sun Apr 16 2017 16:32:49 GMT+0000 (UTC)

I got this error, but maybe it’s because I didn’t actually purchase a domain. Instead, I used a domain I already own (at godaddy) and pointed to the AWS DNS servers. Find it here Hoping I setup the bit properly. As of now, that’s still not working.

From @jayair on Mon Apr 17 2017 17:40:43 GMT+0000 (UTC)

@geirman it looks like the two links are working now?

At which step did you see this error?

From @geirman on Mon Apr 17 2017 19:18:55 GMT+0000 (UTC)

yeah, the www is now working. SSL isn’t. I got the error when I was expecting to receive this…

From @jayair on Mon Apr 17 2017 21:12:44 GMT+0000 (UTC)

Did you hit the limit on the number of certificates you can generate (

If not then you might need to contact AWS.

From @geirman on Mon Apr 17 2017 21:35:29 GMT+0000 (UTC)

I created an account to do your tutorial, so this was the very first certificate i tried to create. Unfortunately, tech support is “Unavailable under the Basic Support Plan”. I’ll try requesting a service limit increase :slight_smile:


From @jayair on Tue Apr 18 2017 17:31:13 GMT+0000 (UTC)

Hmm that’s really strange. It would be good if you could report back once they fix it for you. In case other folks run into similar issues.

From @geirman on Thu Apr 20 2017 12:49:55 GMT+0000 (UTC)

It’s fixed. I requested a “Service Limit Increase” as shown above and received this yesterday (17 hours ago)…

I’m happy to inform you that we’ve approved and processed your Certificate Manager limit increase request for the US East (Northern Virginia) region. Please keep in mind that it can sometimes take up to 15 minutes for this to propagate and become available for use.

I waited 4 hours and tried again, but got no love. However, I tried again this morning and finally found success! Yay!

They unfortunately offered no explanation as to why I needed to make this request at all.

From @jayair on Thu Apr 20 2017 18:00:32 GMT+0000 (UTC)

Yeah their support can be a bit opaque at times.

From @ryanjcruz on Wed May 24 2017 23:34:44 GMT+0000 (UTC)

I encountered an issue wherein the certificate created isn’t showing up - for those having the same one, make sure that the region you are currently in is US EAST (N.Virginia). Turns out I was in US WEST (Oregon) when I created the certificate and it doesn’t seem to propagate right away.

From @henning on Fri Jun 16 2017 13:27:03 GMT+0000 (UTC)

Thanks for the tutorial.

Looks interesting, but I want to avoid to configure services by clicking around a lot, IMHO things should be done with Infrasturcture as code.

So I intend to solve this if possible by adding the proper cloudformation configs to my serverless.yml. Dou you think that’s possible - and easy or hard?

From @jayair on Fri Jun 16 2017 17:30:28 GMT+0000 (UTC)

@henning Some parts of the tutorial can be put into CloudFormation and serverless.yml but there are portions that are not supported by it. I know @nerdguru has been trying to figure that out as well.

And I agree, things should be automated but as a tutorial showing a bunch of CloudFormation templates isn’t very instructive.

From @mmiinnovations on Tue Jul 11 2017 18:16:00 GMT+0000 (UTC)

Great tutorial first off! Thanks for the fine work on it.

Everything worked great until this step. After I setup the SSL and changed the Cloudfront Distributions’ settings, I get “ERR_TOO_MANY_REDIRECTS” error and the app/page won’t load.

I tried setting the CF settings back to what they were. Now I get same “too many redirects” error and it won’t stop redirecting to https even though the settings are back to original. The distributions are marked as “deployed” and I did a invalidations of the caches on both the main and www distributions.


From @jayair on Tue Jul 11 2017 18:57:56 GMT+0000 (UTC)

@mmiinnovations Thank you!

Some of this redirect stuff is a bit confusing. You just need to make sure the redirects are set up the right way. Also because of the CloudFront cache, the changes can take a little bit of time to take effect.

Basically, it looks like:

http://domain -> https://domain
http://www.domain -> https://domain
https://www.domain -> https://domain

To do this our main CF needs the Redirect HTTP to HTTPS but we leave our www CF as HTTP and HTTPS for the Viewer Protocol Policy.

Let me know if your settings look like this.

From @mmiinnovations on Wed Jul 12 2017 04:11:39 GMT+0000 (UTC)

Yes those are my settings.

I found what’s causing the error but not how to fix it. When I set the S3 settings back to “Use this bucket to host a website” everything works fine. When it’s set as the tutorial, I get “ERR_TOO_MANY_REDIRECTS” error. It’s very consistent and repeatable.


From @jayair on Wed Jul 12 2017 16:59:08 GMT+0000 (UTC)

@mmiinnovations You’ve got two S3 buckets right? One of them is hosting a site and the other is doing the redirect.

From @mmiinnovations on Wed Jul 12 2017 17:30:12 GMT+0000 (UTC)

No. I’m very confused if that’s what’s required.

From @jayair on Wed Jul 12 2017 17:33:35 GMT+0000 (UTC)

@mmiinnovations Yeah we need a second S3 bucket to handle the redirect for our www version of the domain. It’s a part of this chapter -

Here is a reason why we do a redirect instead of just pointing both the www and apex domain to the same CloudFront and S3 bucket -

From @mmiinnovations on Wed Jul 12 2017 17:36:27 GMT+0000 (UTC)

OK got it. After reading back through there I see it. I think that section of the tutorial needs just a bit more explanation. It’s confusing and not explained well there.

Not complaining! You guys are great! This tutorial has been awesome. Thanks again for the work you put into it.

From @jayair on Wed Jul 12 2017 17:37:52 GMT+0000 (UTC)

@mmiinnovations Yeah I’ll add a bit more detail to it. Thanks for the feedback!