Set Custom Domains Through Seed

Link to chapter -

Hello @jayair I have been working in this tutorial and in this point I get the following error:

An error ocurred while trying to update the custom domain. Please refresh the pages and try again. You can also contact us if you need any help.

In the first part of the tutorial I buy the domain and I had problems with it. I buy the domain .uk because It is cheaper that .com domain but
I am beginning to believe that It was a bad idea.

Can you recommend to buy a new .com domain and configure again?

I think we were helping you out with the error. But the error is happening because the Certificate Manager is unable to verify that you own the domain.

Btw, did you purchase the domain through Route 53?

Hello @jayair, I buy the domain by… I believe It was another bad idea… I go to apply the process again through Route 53. I hope come with news soon.

1 Like

I buy now the domain and the site is working except the upload of file. The behaviour is the same I posted in

Can you tell me what the issue is? Or post it in that thread?

The error says: NetworkingError: Network Failure when I try upload a file. In the console I receive the following errors and warnings:

Access to XMLHttpRequest at ‘’ from origin ‘’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

Cross-Origin Read Blocking (CORB) blocked cross-origin response with MIME type application/xml. See Chrome Platform Status for more details.

You need to make sure the CORS settings from this chapter are set correctly.

I think I followed the instructions closely but my custom domain is already updating for several hours unsuccessfully but I’m also not able to cancel it or to do anything with it as it still shows the loading icon. Under API Gateways it says “Custom domain not configured”. When I click the link it says {“message”:“Missing Authentication Token”}.

Is this still not working for you?

It worked then after two days for no obvious reason. Probably just took a bit longer…

1 Like

Hey @jayair,

I tried to set up Custom domains through seed for the api gateway.

I received the following error message:
“The DNS server for <my_domain> is not hosted on AWS Route 53.”

My domain was originally registered in and I transferred it to my AWS account a few weeks ago. All went well, I also created a Hosted Domain in Route53 successfully. In the end of tutorial Part I, I also tried to create SSL cert in ACM but the validation is still pending for <my_domain>.com and www.<my_domain>.com. (Also clicked on Create record in Route53 buttons, records are in DNS)

Most likely these two relate to each other. I was wondering how long this validation process takes, why it is not immediate if the domain is managed by AWS Route53. It has been a day now. What can be the issues here? Did anyone have this issue before? I am using an IAM User with admin access.


I managed to fix the issue. When I transferred the domain, the old providers’s DNS server settings came with it. I had to update them with the newly created Hosted Zones’s DNS servers.

1 Like

Ah yeah, it needs to be completely managed by Route 53.

I think im lost with buying domain. As mentioned in the tutorial “In the first part of the tutorial we had added our domain to Route 53” I cant find any guide in the links. Thanks!

1 Like

Thanks for pointing that out. We need to edit that out since our recent update. The start of this chapter should help you:

1 Like

This chapter is really confusing because it assumes you already have a domain name. Then it links to a chapter that shows you how to obtain a domain name from Route 53… But that chapter tells you to point your domain name to your CloudFront distribution which was setup in a different extra credit chapter. It’s all backwards and makes no sense to follow.

1 Like

That’s a good point. After the latest update we kinda messed up the flow. We should split out the domain section from the referenced chapters.

Hi Jayair,

My AWS account is but my github account is Can this be reconciled to I just bought a domain through Route 53 and I can’t see it in Seed?

This step about creating/moving a domain should definitely be flagged much earlier in the tutorial perhaps even right at the start as it takes 3 days to complete which means I’m kinda boxed until then.


It shouldn’t take 3 days to complete. And it shouldn’t be related to the email address on your account. However, make sure you are using the right AWS account and have the appropriate permissions in Seed.

If you can’t figure it out, email with your account and app info.